Cloudflare Zero Trust Dashboard issues

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Sep 09, 2025 - 14:20 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2025 - 14:08 UTC

Identified

Cloudflare identified an issue which potentially impacts multiple customers: Users accessing the "My team > Devices" page under the Zero Trust dashboard may observe an error, or the page might be unavailable. This issue does not affect the connection of any Zero Trust devices that are already configured.
We are working to mitigate this problem, more updates to follow shortly.
Posted Sep 09, 2025 - 14:05 UTC
This incident affected: Cloudflare Sites and Services (Dashboard).