Increased 1003 / 403 errors in Workers

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 08:36 UTC

Monitoring

A fix has been implemented for most customers, we're continuing to rollout a fix for the rest
Posted Apr 02, 2026 - 03:18 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 02, 2026 - 01:10 UTC

Investigating

Cloudflare is aware of and investigating an issue impacting some Workers invocations. Customers may be seeing 1003/403 errors when doing fetch() calls inside a Worker.

We are working to mitigate this problem. More updates to follow shortly.
Posted Apr 02, 2026 - 00:47 UTC
This incident affected: Cloudflare Sites and Services (Workers).