R2 elevated errors during CompleteMultipart operations

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 01:04 UTC

Monitoring

We've deployed a fix for the multipart uploads that were failing on Complete Multipart calls, and error rates have returned to normal levels. We will continue monitoring impact.
Posted Jul 03, 2025 - 00:56 UTC

Identified

We've isolated the pattern leading to Multipart Uploads that are erroring during CompleteMultipartUploads and are preparing a fix for those requests.
Posted Jul 02, 2025 - 23:47 UTC

Investigating

Cloudflare has observed an increase in HTTP 500 responses on some CompleteMultipart API requests containing parts uploaded between 21:03 and 21:26 UTC. We are working to analyze and mitigate this problem. More updates to follow shortly.
Posted Jul 02, 2025 - 21:56 UTC
This incident affected: Cloudflare Sites and Services (R2).