Incorrect geo location for some Cloudflare WARP users

Incident Report for Cloudflare

Update

We are continuing to work on a fix for this issue.
Posted Aug 28, 2026 - 00:55 UTC

Identified

The issue has been identified and we are working with third party providers to fix it.
Posted Aug 27, 2026 - 18:56 UTC

Investigating

Cloudflare is investigating issues with Cloudflare WARP and Cloudflare Zero Trust users being incorrectly geolocated by some third party services.
Posted Aug 27, 2026 - 18:46 UTC
This incident affects: Cloudflare Sites and Services (WARP).