Cache Assets in Buenos Aires

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 02:56 UTC

Investigating

A small percentage of cache assets in buenos aires are seeing elevated latency.

Cloudflare is investigating the issue.
Posted Apr 02, 2026 - 01:07 UTC
This incident affected: Latin America & the Caribbean (Buenos Aires, Argentina - (EZE)) and Cloudflare Sites and Services (CDN/Cache).