Incorrect IP Geolocation on Cloudflare Dashboard

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Dec 23, 2025 - 16:02 UTC

Update

We are continuing to investigate this issue.
Posted Dec 23, 2025 - 10:47 UTC

Investigating

Cloudflare is aware of minor inaccuracies in geolocation data for a very limited number of IP addresses. This may result in some traffic being misidentified as "Unknown" or having an incorrect country/region assignment in the Cloudflare Dashboard.
Posted Dec 23, 2025 - 10:42 UTC
This incident affected: Cloudflare Sites and Services (IP Geolocation).