Network Performance Issues in Phoenix, Los Angeles

Incident Report for Cloudflare

Resolved

This incident is now resolved.
Posted Aug 17, 2026 - 20:44 UTC

Monitoring

We have identified and applied a fix for this issue and are currently monitoring the results.
Posted Aug 17, 2026 - 20:34 UTC

Update

Cloudflare is investigating issues with network performance in our Phoenix and Los Angeles facilities. We are working to analyse and mitigate this problem. More updates to follow shortly.
Posted Aug 17, 2026 - 19:37 UTC

Investigating

Cloudflare is investigating issues with network performance in Phoenix. We are working to analyse and mitigate this problem. More updates to follow shortly.
Posted Aug 17, 2026 - 19:34 UTC
This incident affected: North America (Los Angeles, CA, United States - (LAX), Phoenix, AZ, United States - (PHX)).