User Subscription Update Issues

Incident Report for Cloudflare

Resolved

An effective fix for this issue was identified and implemented. This incident is now resolved.
Posted Sep 11, 2025 - 18:53 UTC

Update

We have determined that this issue affects adding new subscriptions for new products. We are continuing to investigate.
Posted Sep 11, 2025 - 18:33 UTC

Update

We have determined that this issue affects adding new subscriptions for new products. Affected users can still manually add a credit card to work around this issue. We are continuing to investigate.
Posted Sep 11, 2025 - 18:20 UTC

Investigating

We are investigating an issue where users adding R2 for the first time without a payment method already on the account are unable to add a payment method when attempting to enable R2.

Impacted users can manually add a payment method to the account then enable R2 on the account. This issue does not affect existing R2 users.
Posted Sep 11, 2025 - 17:58 UTC
This incident affected: Cloudflare Sites and Services (Subscriptions).