Network Performance Issues in TLV

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 16:25 UTC

Identified

We have identified the source of this issue and are working toward a fix. We have determined that most customers will not be affected by this issue.
Posted Jun 03, 2026 - 16:44 UTC

Update

We are continuing to investigate this issue.
Posted Jun 03, 2026 - 15:39 UTC

Update

We are continuing to investigate this issue.
Posted Jun 03, 2026 - 12:49 UTC

Update

We are continuing to investigate this issue.
Posted Jun 03, 2026 - 10:24 UTC

Update

We are continuing to investigate this issue.
Posted Jun 03, 2026 - 09:03 UTC

Update

We are continuing to investigate this issue.
Posted Jun 03, 2026 - 04:54 UTC

Investigating

Cloudflare is investigating issues with network performance in TLV colos. We are working to analyze and mitigate this problem. More updates to follow shortly.
Posted Jun 02, 2026 - 21:01 UTC
This incident affected: Middle East (Tel Aviv, Israel - (TLV)) and Cloudflare Sites and Services (Network).