Network connectivity issues in Dubai (DXB)

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Aug 22, 2026 - 02:57 UTC

Investigating

Customers in Dubai may see increased error rates while connecting to Cloudflare services.
Posted Aug 22, 2026 - 02:31 UTC
This incident affected: Cloudflare Sites and Services (R2).